summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ast/ast-2.3.0.ebuild')
-rw-r--r--dev-ruby/ast/ast-2.3.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/ast/ast-2.3.0.ebuild b/dev-ruby/ast/ast-2.3.0.ebuild
new file mode 100644
index 000000000000..381f355ca3e5
--- /dev/null
+++ b/dev-ruby/ast/ast-2.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for working with abstract syntax trees"
+HOMEPAGE="https://github.com/whitequark/ast"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/bacon )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e "/git ls/d" ${PN}.gemspec || die
+ sed -i -e "/simplecov/,+11d" -e "/colored_output/d" test/helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Itest -a || die
+}