summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/async-io/async-io-1.36.0.ebuild')
-rw-r--r--dev-ruby/async-io/async-io-1.36.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-ruby/async-io/async-io-1.36.0.ebuild b/dev-ruby/async-io/async-io-1.36.0.ebuild
deleted file mode 100644
index 6a4c6d8896dd..000000000000
--- a/dev-ruby/async-io/async-io-1.36.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby31 ruby32"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_EXTRA_DOC="README.md"
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Provides support for asynchronous TCP, UDP, UNIX and SSL sockets"
-HOMEPAGE="https://github.com/socketry/async-io"
-SRC_URI="https://github.com/socketry/async-io/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1)"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE=""
-
-ruby_add_rdepend "dev-ruby/async"
-
-ruby_add_bdepend "test? (
- >=dev-ruby/async-container-0.15:0
- >=dev-ruby/async-rspec-1.10:1
- dev-ruby/rack-test
-)"
-
-all_ruby_prepare() {
- sed -i -E 's/require_relative "(.+)"/require File.expand_path("\1")/g' "${RUBY_FAKEGEM_GEMSPEC}" || die
-
- # Avoid test dependency on covered
- sed -i -e '/covered/ s:^:#:' spec/spec_helper.rb || die
-}