summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/atomic/atomic-1.1.101.ebuild')
-rw-r--r--dev-ruby/atomic/atomic-1.1.101.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-ruby/atomic/atomic-1.1.101.ebuild b/dev-ruby/atomic/atomic-1.1.101.ebuild
deleted file mode 100644
index b2301eb94cfe..000000000000
--- a/dev-ruby/atomic/atomic-1.1.101.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="An atomic reference implementation for JRuby, Rubinius, and MRI"
-HOMEPAGE="https://github.com/headius/ruby-atomic"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ~hppa ppc ppc64 ~sparc x86"
-IUSE=""
-
-all_ruby_prepare() {
- # Avoid compilation dependencies since we compile directly.
- sed -i -e '/:test => :compile/ s:^:#:' \
- -e '/extensiontask/,/end/ s:^:#:' Rakefile || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext extconf.rb || die
-}
-
-each_ruby_compile() {
- emake V=1 -Cext
- cp ext/atomic_reference$(get_modname) lib/ || die
-}