summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.0.ebuild')
-rw-r--r--dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.0.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.0.ebuild b/dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.0.ebuild
index 692e9373f3d6..0370d8002246 100644
--- a/dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.0.ebuild
+++ b/dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.0.ebuild
@@ -30,6 +30,9 @@ all_ruby_prepare() {
each_ruby_configure() {
${RUBY} -Cext/mri extconf.rb || die
+
+ # Some methods may not be inlined on x86 but they are not defined either, bug 629164
+ sed -i -e 's:-Wl,--no-undefined::' ext/mri/Makefile || die
}
each_ruby_compile() {