summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/binding_of_caller/binding_of_caller-0.7.3.ebuild')
-rw-r--r--dev-ruby/binding_of_caller/binding_of_caller-0.7.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/binding_of_caller/binding_of_caller-0.7.3.ebuild b/dev-ruby/binding_of_caller/binding_of_caller-0.7.3.ebuild
new file mode 100644
index 000000000000..db88afa35d4e
--- /dev/null
+++ b/dev-ruby/binding_of_caller/binding_of_caller-0.7.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="HISTORY README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the binding of a method's caller"
+HOMEPAGE="https://github.com/banister/binding_of_caller"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/debug_inspector-0.0.1"
+
+ruby_add_bdepend "test? ( dev-ruby/bacon )"
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Itest -rubygems -a -q || die
+}