summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/binding_of_caller')
-rw-r--r--dev-ruby/binding_of_caller/Manifest1
-rw-r--r--dev-ruby/binding_of_caller/binding_of_caller-1.0.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/binding_of_caller/Manifest b/dev-ruby/binding_of_caller/Manifest
index 66a1b369f1bc..b45105f01e74 100644
--- a/dev-ruby/binding_of_caller/Manifest
+++ b/dev-ruby/binding_of_caller/Manifest
@@ -1 +1,2 @@
DIST binding_of_caller-0.8.0.gem 87552 BLAKE2B 9097fe2dbf1e5ea2361bee94cb83ce8152f7e1357caecf1217b1643be225e21e5aa793e7fccbef5c983d5c204b95e633ded490158dfdd1d4e99fca81c51cb910 SHA512 d6ea4e893415eaf3614b109f8f36c3fa2378da9997d013fccbd0fc1e598886d11f7843023ceed2468184d5b8df01e2329ef16c7af57bc60bbd47304a53b43974
+DIST binding_of_caller-1.0.0.tar.gz 7473 BLAKE2B 2a8f3cee555e11c9eeb56935d0ee51deb037ea5fc631b4ef5eb50a831e48ba47c6a94e9104456bd8e6c4910bc76c5bc7e268db7de8c5ed283886b80c3feffd62 SHA512 89c58fec180b7bc25c5124035ed69692961148a3ddcb561643e7b8b1a78c3b103795408b52e70264db7c4b62080991219af977c5b981a135d573ecd56cebebba
diff --git a/dev-ruby/binding_of_caller/binding_of_caller-1.0.0.ebuild b/dev-ruby/binding_of_caller/binding_of_caller-1.0.0.ebuild
new file mode 100644
index 000000000000..47de67cdbd75
--- /dev/null
+++ b/dev-ruby/binding_of_caller/binding_of_caller-1.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="binding_of_caller.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the binding of a method's caller"
+HOMEPAGE="https://github.com/banister/binding_of_caller"
+SRC_URI="https://github.com/banister/binding_of_caller/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/debug_inspector-0.0.1"
+
+all_ruby_prepare() {
+ sed -i -e "s:_relative ': './:" -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+}