summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/bitescript/bitescript-0.0.9.ebuild')
-rw-r--r--dev-ruby/bitescript/bitescript-0.0.9.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/bitescript/bitescript-0.0.9.ebuild b/dev-ruby/bitescript/bitescript-0.0.9.ebuild
new file mode 100644
index 000000000000..c4d7c4f0b7a5
--- /dev/null
+++ b/dev-ruby/bitescript/bitescript-0.0.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="BiteScript is a Ruby DSL for generating Java bytecode and classes"
+HOMEPAGE="http://kenai.com/projects/bitescript"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}