summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/capistrano/capistrano-3.11.1.ebuild')
-rw-r--r--dev-ruby/capistrano/capistrano-3.11.1.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-ruby/capistrano/capistrano-3.11.1.ebuild b/dev-ruby/capistrano/capistrano-3.11.1.ebuild
deleted file mode 100644
index 5e35dba14f3f..000000000000
--- a/dev-ruby/capistrano/capistrano-3.11.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A distributed application deployment system"
-HOMEPAGE="https://capistranorb.com/"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/airbrussh-1.0.0
- >=dev-ruby/sshkit-1.9:0
- >=dev-ruby/rake-10.0.0
- dev-ruby/i18n:*
- !!<dev-ruby/capistrano-2.15.5-r2"
-ruby_add_bdepend "
- test? ( dev-ruby/mocha )"
-
-all_ruby_prepare() {
- # Avoid specs that depend on capistrano already being installed
- rm -f spec/lib/capistrano/doctor/gems_doctor_spec.rb || die
-
- # Avoid specs that require a TTY
- sed -i -e '/asking for a variable/,/^ end/ s:^:#:' spec/integration/dsl_spec.rb || die
- rm -f spec/lib/capistrano/configuration/question_spec.rb || die
-}