summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/climate_control/climate_control-0.2.0.ebuild')
-rw-r--r--dev-ruby/climate_control/climate_control-0.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/climate_control/climate_control-0.2.0.ebuild b/dev-ruby/climate_control/climate_control-0.2.0.ebuild
new file mode 100644
index 000000000000..64d71cae53f1
--- /dev/null
+++ b/dev-ruby/climate_control/climate_control-0.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="NEWS README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Easily manage your environment"
+HOMEPAGE="https://github.com/thoughtbot/climate_control"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid dependencies on simplecov and git.
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+ sed -i -e 's/git ls-files/echo ""/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}