summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/colorize/colorize-0.8.1-r2.ebuild')
-rw-r--r--dev-ruby/colorize/colorize-0.8.1-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/colorize/colorize-0.8.1-r2.ebuild b/dev-ruby/colorize/colorize-0.8.1-r2.ebuild
new file mode 100644
index 000000000000..43adf45d8016
--- /dev/null
+++ b/dev-ruby/colorize/colorize-0.8.1-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Adds methods to set color, background color and text effect on console easier"
+HOMEPAGE="https://github.com/fazibear/colorize"
+LICENSE="GPL-2+"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Cc]ode[Cc]limate/d" test/test_colorize.rb || die
+}
+
+each_ruby_test() {
+ cd test || die
+ ${RUBY} test_colorize.rb || die
+}