summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/curb')
-rw-r--r--dev-ruby/curb/curb-1.0.5.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-ruby/curb/curb-1.0.5.ebuild b/dev-ruby/curb/curb-1.0.5.ebuild
index b3e54dfe34cb..87a4cb375d1a 100644
--- a/dev-ruby/curb/curb-1.0.5.ebuild
+++ b/dev-ruby/curb/curb-1.0.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby30 ruby31 ruby32"
+USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_RECIPE_TEST="rake"
@@ -17,11 +17,13 @@ HOMEPAGE="https://github.com/taf2/curb"
LICENSE="Ruby"
SLOT="0"
KEYWORDS="amd64"
-IUSE=""
+IUSE="test"
DEPEND+=" net-misc/curl[ssl] test? ( net-misc/curl )"
RDEPEND+=" net-misc/curl[ssl]"
+ruby_add_bdepend "test? ( dev-ruby/webrick )"
+
all_ruby_prepare() {
# fix tests when localhost is also ::1
sed -i -e 's|localhost:|127.0.0.1:|g' tests/*.rb || die