summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/dalli')
-rw-r--r--dev-ruby/dalli/Manifest5
-rw-r--r--dev-ruby/dalli/dalli-2.7.11.ebuild50
-rw-r--r--dev-ruby/dalli/dalli-3.2.5.ebuild43
-rw-r--r--dev-ruby/dalli/dalli-3.2.6.ebuild44
-rw-r--r--dev-ruby/dalli/dalli-3.2.7.ebuild44
-rw-r--r--dev-ruby/dalli/dalli-3.2.8.ebuild44
6 files changed, 179 insertions, 51 deletions
diff --git a/dev-ruby/dalli/Manifest b/dev-ruby/dalli/Manifest
index c6651dff8a5c..b4c8649bea05 100644
--- a/dev-ruby/dalli/Manifest
+++ b/dev-ruby/dalli/Manifest
@@ -1 +1,4 @@
-DIST dalli-2.7.11.tar.gz 52341 BLAKE2B 5b3a2bc57f4b0e3a9ac0d24ffa3bba89ea38665ac08ef3d7760fa6ce74db21d323a18e74a4f3009165364332731d7c6890df36c68409afbe21d3ac096275f028 SHA512 8f299a19d95293370564b6337bbdfeb32d928e0a95bf5f5df962ea20b039f4765da1797513ca96cabf93309484575481a02fb1e0c6d227f74c81fc72f95be22a
+DIST dalli-3.2.5.tar.gz 72496 BLAKE2B 2a8665aad98629ccab873a2b6b6661304b25dd2374ed3685f97dee83bf43c604088e43229ced951453d889fab7a1ec35b7fb3f0028858cf890a6013ac82b64c1 SHA512 ace079e3c9f7c30e2f266a07f87e58cbf4276f5ca4744ade76782a6a6047296bf5e23d40a4c1f4596b1eb150501c460f7cf89b33f308a774bcfe5825ec635760
+DIST dalli-3.2.6.tar.gz 72683 BLAKE2B d3cf252862d796cb0e8320df0b35af91678949b1dc564054585252e98caed70681609857b7606663b4bda08a27112bc1d51779fc29ef045d0ec087ba80d6dfdd SHA512 93aa808123adb671c096543271407e497770a8f7481a961f48f11493f3a313113f0ec7829708d7352c0ade1f02a9842ecfc22ba7d93beb138db981d2bd1b94a9
+DIST dalli-3.2.7.tar.gz 73058 BLAKE2B 8baba122e1bba1254e38ed021ac0c494c27bccf65d99aa16f379824073457e2eb7f79b2e9ec4cb49153b682c48d6bdfdcbe64966a286dba7b45349ace81ca4a1 SHA512 771bb0863e86cd7c252cfc1a688dd820b3efd24d6038be8789e2d4c2604703b78b64d36d0b32bb81001d625fc116eb86b4421cb3b32de8918912a3995e68ee70
+DIST dalli-3.2.8.tar.gz 73367 BLAKE2B 1680fda0d272d135f8e88a0ea2e16a08cd1027808f0503334b8c53dd85472cc7c37df3649623f8347169f5b8cd645c9a1a4d98343e45d4369ce8d08cc1306316 SHA512 85a0d8121fd0e539b0fd6c15716971d91e91741d36850cf8e887d8fef17d6b49ea6036ce66c986aafd008aa0e744cd798bc574e9376383b9af33b0971e31e25c
diff --git a/dev-ruby/dalli/dalli-2.7.11.ebuild b/dev-ruby/dalli/dalli-2.7.11.ebuild
deleted file mode 100644
index a918291870bd..000000000000
--- a/dev-ruby/dalli/dalli-2.7.11.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="History.md Performance.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A high performance pure Ruby client for accessing memcached servers"
-HOMEPAGE="https://github.com/petergoldstein/dalli"
-SRC_URI="https://github.com/petergoldstein/dalli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv x86"
-IUSE=""
-
-DEPEND+="${DEPEND} test? ( >=net-misc/memcached-1.5.4 )"
-
-ruby_add_bdepend "test? (
- dev-ruby/minitest:5
- >=dev-ruby/mocha-0.13
- dev-ruby/rack
- >=dev-ruby/activesupport-5.2
- dev-ruby/connection_pool )"
-
-all_ruby_prepare() {
- chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
-
- sed -i -e '/\(appraisal\|bundler\)/ s:^:#:' Rakefile || die
-
- sed -i -e '3igem "minitest", "~> 5.0"; gem "activesupport", ">=5.2.0"' \
- -e '/bundler/ s:^:#:' test/helper.rb || die
-
- # Drop rails dependency which is only used to display the version
- # number, so we only need to depend on activesupport and avoid
- # complicated circular dependencies.
- sed -i -e '/rails/I s:^:#:' \
- -e '14irequire "active_support"' test/helper.rb || die
-
- # Fix test compatability with memcached 1.5.4 and higher
- # https://github.com/petergoldstein/dalli/pull/672
- #sed -i -e '/memcached_low_mem_persistent/,/^end/ s/-M/-M -I 512k/' test/memcached_mock.rb || die
-}
diff --git a/dev-ruby/dalli/dalli-3.2.5.ebuild b/dev-ruby/dalli/dalli-3.2.5.ebuild
new file mode 100644
index 000000000000..6d0b4ea322a8
--- /dev/null
+++ b/dev-ruby/dalli/dalli-3.2.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_TASK_TEST="MT_NO_PLUGINS=true test"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md Performance.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance pure Ruby client for accessing memcached servers"
+HOMEPAGE="https://github.com/petergoldstein/dalli"
+SRC_URI="https://github.com/petergoldstein/dalli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 x86"
+IUSE=""
+
+DEPEND+="${DEPEND} test? ( >=net-misc/memcached-1.5.4[ssl(-)] )"
+
+ruby_add_bdepend "test? (
+ dev-ruby/connection_pool
+ dev-ruby/minitest:5
+ dev-ruby/rack:2.2
+)"
+
+all_ruby_prepare() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ sed -i -e '/\(appraisal\|bundler\)/ s:^:#:' Rakefile || die
+
+ sed -i -e '3igem "minitest", "~> 5.0"; gem "rack", "~> 2.2.0"; require "dalli"' \
+ -e '/bundler/ s:^:#:' test/helper.rb || die
+
+ sed -i -e "s:/tmp:${T}:" test/utils/certificate_generator.rb || die
+}
diff --git a/dev-ruby/dalli/dalli-3.2.6.ebuild b/dev-ruby/dalli/dalli-3.2.6.ebuild
new file mode 100644
index 000000000000..9e4f2ecb1ef2
--- /dev/null
+++ b/dev-ruby/dalli/dalli-3.2.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_TASK_TEST="MT_NO_PLUGINS=true test"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md Performance.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance pure Ruby client for accessing memcached servers"
+HOMEPAGE="https://github.com/petergoldstein/dalli"
+SRC_URI="https://github.com/petergoldstein/dalli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~x86"
+IUSE=""
+
+DEPEND+="${DEPEND} test? ( >=net-misc/memcached-1.5.4[ssl(-)] )"
+
+ruby_add_bdepend "test? (
+ dev-ruby/connection_pool
+ dev-ruby/minitest:5
+ dev-ruby/rack
+ dev-ruby/rack-session
+)"
+
+all_ruby_prepare() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ sed -i -e '/\(appraisal\|bundler\)/ s:^:#:' Rakefile || die
+
+ sed -i -e '3igem "minitest", "~> 5.0"; require "dalli"' \
+ -e '/bundler/ s:^:#:' test/helper.rb || die
+
+ sed -i -e "s:/tmp:${T}:" test/utils/certificate_generator.rb || die
+}
diff --git a/dev-ruby/dalli/dalli-3.2.7.ebuild b/dev-ruby/dalli/dalli-3.2.7.ebuild
new file mode 100644
index 000000000000..41af68f1391e
--- /dev/null
+++ b/dev-ruby/dalli/dalli-3.2.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_TASK_TEST="MT_NO_PLUGINS=true test"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md Performance.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance pure Ruby client for accessing memcached servers"
+HOMEPAGE="https://github.com/petergoldstein/dalli"
+SRC_URI="https://github.com/petergoldstein/dalli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~x86"
+IUSE="test"
+
+DEPEND+="${DEPEND} test? ( >=net-misc/memcached-1.5.4[ssl(-)] )"
+
+ruby_add_bdepend "test? (
+ dev-ruby/connection_pool
+ dev-ruby/minitest:5
+ dev-ruby/rack
+ dev-ruby/rack-session
+)"
+
+all_ruby_prepare() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ sed -i -e '/\(appraisal\|bundler\)/ s:^:#:' Rakefile || die
+
+ sed -i -e '3igem "minitest", "~> 5.0"; require "dalli"' \
+ -e '/bundler/ s:^:#:' test/helper.rb || die
+
+ sed -i -e "s:/tmp:${T}:" test/utils/certificate_generator.rb || die
+}
diff --git a/dev-ruby/dalli/dalli-3.2.8.ebuild b/dev-ruby/dalli/dalli-3.2.8.ebuild
new file mode 100644
index 000000000000..41af68f1391e
--- /dev/null
+++ b/dev-ruby/dalli/dalli-3.2.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_TASK_TEST="MT_NO_PLUGINS=true test"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md Performance.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance pure Ruby client for accessing memcached servers"
+HOMEPAGE="https://github.com/petergoldstein/dalli"
+SRC_URI="https://github.com/petergoldstein/dalli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~x86"
+IUSE="test"
+
+DEPEND+="${DEPEND} test? ( >=net-misc/memcached-1.5.4[ssl(-)] )"
+
+ruby_add_bdepend "test? (
+ dev-ruby/connection_pool
+ dev-ruby/minitest:5
+ dev-ruby/rack
+ dev-ruby/rack-session
+)"
+
+all_ruby_prepare() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ sed -i -e '/\(appraisal\|bundler\)/ s:^:#:' Rakefile || die
+
+ sed -i -e '3igem "minitest", "~> 5.0"; require "dalli"' \
+ -e '/bundler/ s:^:#:' test/helper.rb || die
+
+ sed -i -e "s:/tmp:${T}:" test/utils/certificate_generator.rb || die
+}