summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/fake_ftp/fake_ftp-0.3.0.ebuild')
-rw-r--r--dev-ruby/fake_ftp/fake_ftp-0.3.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/fake_ftp/fake_ftp-0.3.0.ebuild b/dev-ruby/fake_ftp/fake_ftp-0.3.0.ebuild
new file mode 100644
index 000000000000..336cf5b23e41
--- /dev/null
+++ b/dev-ruby/fake_ftp/fake_ftp-0.3.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Testing FTP? Use this!"
+HOMEPAGE="https://github.com/livinginthepast/fake_ftp"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/ s:^:#:' spec/spec_helper.rb || die
+}