summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/hiera/hiera-3.0.5.ebuild')
-rw-r--r--dev-ruby/hiera/hiera-3.0.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/hiera/hiera-3.0.5.ebuild b/dev-ruby/hiera/hiera-3.0.5.ebuild
new file mode 100644
index 000000000000..4251514194e2
--- /dev/null
+++ b/dev-ruby/hiera/hiera-3.0.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple pluggable Hierarchical Database"
+HOMEPAGE="http://projects.puppetlabs.com/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~hppa ~x86"
+
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+ruby_add_rdepend "dev-ruby/json
+ dev-ruby/deep_merge"
+
+all_ruby_prepare() {
+ # Our json package is either the compiled version or the pure
+ # version. Fix gemspec accordingly.
+ sed -i -e 's/json_pure/json/' ../metadata || die
+}