summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/hocon/hocon-1.3.0.ebuild')
-rw-r--r--dev-ruby/hocon/hocon-1.3.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/hocon/hocon-1.3.0.ebuild b/dev-ruby/hocon/hocon-1.3.0.ebuild
new file mode 100644
index 000000000000..c9a3580f249f
--- /dev/null
+++ b/dev-ruby/hocon/hocon-1.3.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_BINWRAP="hocon"
+
+RUBY_FAKEGEM_GEMSPEC="hocon.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This is a port of the Typesafe Config library to Ruby."
+HOMEPAGE="https://github.com/puppetlabs/ruby-hocon"
+SRC_URI="https://github.com/puppetlabs/ruby-hocon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-hocon-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"