summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/httpauth/httpauth-0.2.1.ebuild')
-rw-r--r--dev-ruby/httpauth/httpauth-0.2.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/httpauth/httpauth-0.2.1.ebuild b/dev-ruby/httpauth/httpauth-0.2.1.ebuild
new file mode 100644
index 000000000000..f196221ad5fc
--- /dev/null
+++ b/dev-ruby/httpauth/httpauth-0.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md TODO"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library supporting the full HTTP Authentication protocol as specified in RFC 2617"
+HOMEPAGE="https://github.com/Manfred/HTTPauth"
+SRC_URI="https://github.com/Manfred/HTTPauth/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+RUBY_S=HTTPauth-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+}