summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/json/json-2.6.3.ebuild')
-rw-r--r--dev-ruby/json/json-2.6.3.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/dev-ruby/json/json-2.6.3.ebuild b/dev-ruby/json/json-2.6.3.ebuild
index 6fdae306ab6c..73b8f0373091 100644
--- a/dev-ruby/json/json-2.6.3.ebuild
+++ b/dev-ruby/json/json-2.6.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
RUBY_FAKEGEM_DOCDIR="doc"
@@ -18,7 +18,7 @@ HOMEPAGE="https://github.com/flori/json"
SRC_URI="https://github.com/flori/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="|| ( BSD-2 Ruby )"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
SLOT="2"
IUSE=""
@@ -41,10 +41,6 @@ all_ruby_prepare() {
-e 's|`git ls-files`|""|' \
Rakefile || die "rakefile fix failed"
- # Remove hardcoded and broken -O setting.
- sed -i -e '/^ \(if\|unless\)/,/^ end/ s:^:#:' \
- -e '/^unless/,/^end/ s:^:#:' ext/json/ext/*/extconf.rb || die
-
# Avoid setting gem since it will not be available yet when installing
sed -i -e '/gem/ s:^:#:' tests/test_helper.rb || die
}