summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/json_schema/json_schema-0.21.0.ebuild')
-rw-r--r--dev-ruby/json_schema/json_schema-0.21.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/json_schema/json_schema-0.21.0.ebuild b/dev-ruby/json_schema/json_schema-0.21.0.ebuild
new file mode 100644
index 000000000000..5a7f5c83c528
--- /dev/null
+++ b/dev-ruby/json_schema/json_schema-0.21.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md TODO.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="schemas"
+
+RUBY_FAKEGEM_GEMSPEC="json_schema.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A JSON Schema V4 and Hyperschema V4 parser and validator"
+HOMEPAGE="https://github.com/brandur/json_schema"
+SRC_URI="https://github.com/brandur/json_schema/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/ecma-re-validator )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+ sed -i -e '/^if/,/^end/ s:^:#:' test/test_helper.rb || die
+
+ sed -e '/validates date format successfully/askip "should fail like test after it"' \
+ -i test/json_schema/validator_test.rb || die
+}