summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/maildir/maildir-2.2.1-r1.ebuild')
-rw-r--r--dev-ruby/maildir/maildir-2.2.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/maildir/maildir-2.2.1-r1.ebuild b/dev-ruby/maildir/maildir-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..58a9690259b9
--- /dev/null
+++ b/dev-ruby/maildir/maildir-2.2.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="README.rdoc"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for reading and writing arbitrary messages in DJB's maildir format"
+HOMEPAGE="https://github.com/ktheory/maildir"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="2"
+IUSE="test"
+
+ruby_add_bdepend "
+ test? ( >=dev-ruby/fakefs-0.3.2 dev-ruby/mail dev-ruby/shoulda-context dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile test/helper.rb || die
+ sed -i -e 's/shoulda/shoulda-context/' test/helper.rb || die
+
+ # Avoid tests that appear to need activesupport for .blank? support
+ sed -i -e '/add and remove flags/,/^ end/ s:^:#:' test/test_message.rb || die
+ sed -i -e '/be removed from flag list/,/^ end/ s:^:#:' test/test_maildir.rb || die
+}