summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/minispec-metadata/minispec-metadata-3.3.1-r1.ebuild')
-rw-r--r--dev-ruby/minispec-metadata/minispec-metadata-3.3.1-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/minispec-metadata/minispec-metadata-3.3.1-r1.ebuild b/dev-ruby/minispec-metadata/minispec-metadata-3.3.1-r1.ebuild
new file mode 100644
index 000000000000..856e71f71964
--- /dev/null
+++ b/dev-ruby/minispec-metadata/minispec-metadata-3.3.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Define and access metadata in MiniTest::Spec descriptions and specs"
+HOMEPAGE="https://github.com/ordinaryzelig/minispec-metadata"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/minitest"
+
+all_ruby_prepare() {
+ sed -i -e '/\(bundler\|awesome_print\)/ s:^:#:' Rakefile spec/helper.rb || die
+}