summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/minitest-around')
-rw-r--r--dev-ruby/minitest-around/Manifest1
-rw-r--r--dev-ruby/minitest-around/metadata.xml11
-rw-r--r--dev-ruby/minitest-around/minitest-around-0.5.0.ebuild34
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/minitest-around/Manifest b/dev-ruby/minitest-around/Manifest
new file mode 100644
index 000000000000..b2daff263804
--- /dev/null
+++ b/dev-ruby/minitest-around/Manifest
@@ -0,0 +1 @@
+DIST minitest-around-0.5.0.gem 11776 BLAKE2B 1b1bacc229252e41412380d95e50ad05f918c13d37e7939f96fa19e4254c7f5222482d0f080355e5a900ff8ef89f768cc527c9b1c2644817e4d46842cbf83140 SHA512 8e57d436d39a41c5a08df6006a5cd46f92550844f01f9b6662918b9ba9536b74f6c83fcaea64180c7e025a1a14d4e037e1b17b84ae395a2b745e58f21ba5c752
diff --git a/dev-ruby/minitest-around/metadata.xml b/dev-ruby/minitest-around/metadata.xml
new file mode 100644
index 000000000000..4cbe1280bf75
--- /dev/null
+++ b/dev-ruby/minitest-around/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">splattael/minitest-around</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/minitest-around/minitest-around-0.5.0.ebuild b/dev-ruby/minitest-around/minitest-around-0.5.0.ebuild
new file mode 100644
index 000000000000..286620470fb8
--- /dev/null
+++ b/dev-ruby/minitest-around/minitest-around-0.5.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Alternative for setup/teardown dance"
+HOMEPAGE="https://github.com/splattael/minitest-around"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/minitest:5"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-util/cucumber )"
+
+all_ruby_prepare() {
+ sed -i -e '/bump/ s:^:#:' \
+ -e '/ls-files/d' \
+ -e '/cucumber/ s/,.*$//' minitest-around.gemspec Rakefile || die
+}
+
+each_ruby_test() {
+ for f in test/*_{test,spec}.rb ; do
+ ${RUBY} -S rake test:isolated TEST="${f}" || die
+ done
+}