summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/net-ftp/net-ftp-0.2.0.ebuild')
-rw-r--r--dev-ruby/net-ftp/net-ftp-0.2.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/net-ftp/net-ftp-0.2.0.ebuild b/dev-ruby/net-ftp/net-ftp-0.2.0.ebuild
new file mode 100644
index 000000000000..87b1ff8c5865
--- /dev/null
+++ b/dev-ruby/net-ftp/net-ftp-0.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="net-ftp.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Support for the File Transfer Protocol"
+HOMEPAGE="https://github.com/ruby/net-ftp"
+SRC_URI="https://github.com/ruby/net-ftp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/net-protocol
+ dev-ruby/time
+"
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}