summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/net-smtp')
-rw-r--r--dev-ruby/net-smtp/Manifest4
-rw-r--r--dev-ruby/net-smtp/net-smtp-0.3.3.ebuild (renamed from dev-ruby/net-smtp/net-smtp-0.3.1.ebuild)8
-rw-r--r--dev-ruby/net-smtp/net-smtp-0.4.0.ebuild31
-rw-r--r--dev-ruby/net-smtp/net-smtp-0.5.0.ebuild30
4 files changed, 67 insertions, 6 deletions
diff --git a/dev-ruby/net-smtp/Manifest b/dev-ruby/net-smtp/Manifest
index 5f64d5deaddc..5aa2be16ab64 100644
--- a/dev-ruby/net-smtp/Manifest
+++ b/dev-ruby/net-smtp/Manifest
@@ -1 +1,3 @@
-DIST net-smtp-0.3.1.tar.gz 24465 BLAKE2B 200af603428dde4daf79aaac426525e1d7e2533995dcda4e2b96daaf64900558fd1717086215bf35cba9fd6db732d2d5a4b529531508a757197dc174a9f905b3 SHA512 68807d204f7768a3d890c0fd1076b2d7f77be3df662549ae9cfb56c8f84491cf4948addeb47399cdc9e7580e175e9d20ddeca25da8daafb3a90b880cc39a81ae
+DIST net-smtp-0.3.3.tar.gz 25297 BLAKE2B 29339faf7c7a3870b2eed7d2b9058ad7b3beaae9bddd3fe718cbcba0c65faa3e118916ac2e2a8cfc9e52c602bde301929c037856b68e42881bdab3ecbb90b01f SHA512 1936cede296d899f2cbcf5874b1472e808255cca21788037f6e8f38f8b1ef05779fec0c4f51a3970c09191078fee84c85e909eb9223034bdc293a1215b004ad1
+DIST net-smtp-0.4.0.tar.gz 26695 BLAKE2B 4ae79a5288ccb55b9a9bcd377ef3c85123a55b9269815730b2fb394ba98469ecaa7a5fc3230bc4a2e9117bff62453a69b627a397db1ca4f63f0cbd4856510d4e SHA512 3a130daac6392dd9328bdc644e1089eb34f290658b06f4aee48ab9f407086446af9fe674c5f417251ffb04478e5a6f14829f2b13b3e62fadb65ac09a2fa35bc1
+DIST net-smtp-0.5.0.tar.gz 26026 BLAKE2B 9969354a7f0fc4a32beac965bfc325aa54a1687d28ee7a4828005bbee1cabcaeefb4ffcdd019761c9162c7623efeccc8a4cb7222df004c75cbc1cced5242df3f SHA512 bf497150a4b7f59307ddedd02b1b210b971ba0de0d7459872d01a7db8175bb42c29598b5e9b6efdbdf90cc012696da2e000149246e1142a5695e7fe646aa6fa8
diff --git a/dev-ruby/net-smtp/net-smtp-0.3.1.ebuild b/dev-ruby/net-smtp/net-smtp-0.3.3.ebuild
index 6a5d70ff99e2..fc25cb4c581a 100644
--- a/dev-ruby/net-smtp/net-smtp-0.3.1.ebuild
+++ b/dev-ruby/net-smtp/net-smtp-0.3.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_BINWRAP=""
RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
@@ -16,13 +16,11 @@ SRC_URI="https://github.com/ruby/net-smtp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
IUSE=""
ruby_add_rdepend "
- dev-ruby/digest
dev-ruby/net-protocol
- dev-ruby/timeout
"
all_ruby_prepare() {
diff --git a/dev-ruby/net-smtp/net-smtp-0.4.0.ebuild b/dev-ruby/net-smtp/net-smtp-0.4.0.ebuild
new file mode 100644
index 000000000000..ec05e4f513c7
--- /dev/null
+++ b/dev-ruby/net-smtp/net-smtp-0.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+RUBY_FAKEGEM_GEMSPEC="net-smtp.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple Mail Transfer Protocol client library for Ruby"
+HOMEPAGE="https://github.com/ruby/net-smtp"
+SRC_URI="https://github.com/ruby/net-smtp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/net-protocol
+"
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
diff --git a/dev-ruby/net-smtp/net-smtp-0.5.0.ebuild b/dev-ruby/net-smtp/net-smtp-0.5.0.ebuild
new file mode 100644
index 000000000000..f208e2f17bd8
--- /dev/null
+++ b/dev-ruby/net-smtp/net-smtp-0.5.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+RUBY_FAKEGEM_GEMSPEC="net-smtp.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple Mail Transfer Protocol client library for Ruby"
+HOMEPAGE="https://github.com/ruby/net-smtp"
+SRC_URI="https://github.com/ruby/net-smtp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+ruby_add_rdepend "
+ dev-ruby/net-protocol
+"
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}