summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/network_interface/network_interface-0.0.2-r1.ebuild')
-rw-r--r--dev-ruby/network_interface/network_interface-0.0.2-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/network_interface/network_interface-0.0.2-r1.ebuild b/dev-ruby/network_interface/network_interface-0.0.2-r1.ebuild
new file mode 100644
index 000000000000..2e4c2572c5a2
--- /dev/null
+++ b/dev-ruby/network_interface/network_interface-0.0.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/network_interface_ext/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="network_interface layer from metasploit pcaprub"
+HOMEPAGE="https://github.com/rapid7/network_interface"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+# Tests are brittle as they cannot deal with all network interface configurations.
+RESTRICT="test"
+
+all_ruby_prepare() {
+ sed -i -e 's:/sbin/ifconfig:/bin/ifconfig:' spec/spec_helper.rb || die
+}