summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ox/ox-2.10.0.ebuild')
-rw-r--r--dev-ruby/ox/ox-2.10.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-ruby/ox/ox-2.10.0.ebuild b/dev-ruby/ox/ox-2.10.0.ebuild
deleted file mode 100644
index 997658880e31..000000000000
--- a/dev-ruby/ox/ox-2.10.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A fast XML parser and Object marshaller"
-HOMEPAGE="http://www.ohler.com/ox/ https://github.com/ohler55/ox"
-SRC_URI="https://github.com/ohler55/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-SLOT="0"
-IUSE=""
-
-all_ruby_prepare() {
- # Avoid test that depends on did_you_mean implementation details
- sed -i -e '/test_nameerror/aomit' test/tests.rb || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/ox extconf.rb || die
-}
-
-each_ruby_compile() {
- emake V=1 -Cext/ox
- cp ext/ox/ox$(get_modname) lib/ox/ || die
-}
-
-each_ruby_test() {
- ${RUBY} test/tests.rb || die
-}