summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/pcaprub/pcaprub-0.12.0-r1.ebuild')
-rw-r--r--dev-ruby/pcaprub/pcaprub-0.12.0-r1.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-ruby/pcaprub/pcaprub-0.12.0-r1.ebuild b/dev-ruby/pcaprub/pcaprub-0.12.0-r1.ebuild
deleted file mode 100644
index 431dffb69a8c..000000000000
--- a/dev-ruby/pcaprub/pcaprub-0.12.0-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21 ruby22"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="FAQ.rdoc README.rdoc USAGE.rdoc"
-
-inherit multilib ruby-fakegem versionator
-
-DESCRIPTION="Libpcap bindings for ruby compat"
-HOMEPAGE="https://rubygems.org/gems/pcaprub"
-
-LICENSE="LGPL-2.1"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~x86"
-
-DEPEND+="net-libs/libpcap"
-RDEPEND+="net-libs/libpcap"
-
-# Tests require live access to a network device as root.
-RESTRICT="test"
-
-each_ruby_configure() {
- ${RUBY} -Cext/pcaprub_c extconf.rb || die
-}
-
-each_ruby_compile() {
- emake -C ext/pcaprub_c V=1
- cp ext/pcaprub_c/pcaprub_c$(get_modname) lib || die
-}