summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/pcaprub/pcaprub-0.13.0.ebuild')
-rw-r--r--dev-ruby/pcaprub/pcaprub-0.13.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/pcaprub/pcaprub-0.13.0.ebuild b/dev-ruby/pcaprub/pcaprub-0.13.0.ebuild
new file mode 100644
index 000000000000..d85148c26b66
--- /dev/null
+++ b/dev-ruby/pcaprub/pcaprub-0.13.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="FAQ.rdoc README.rdoc USAGE.rdoc"
+
+inherit multilib ruby-fakegem eapi7-ver
+
+DESCRIPTION="Libpcap bindings for ruby compat"
+HOMEPAGE="https://rubygems.org/gems/pcaprub"
+
+LICENSE="LGPL-2.1"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DEPEND+="net-libs/libpcap"
+RDEPEND+="net-libs/libpcap"
+
+# Tests require live access to a network device as root.
+RESTRICT="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/pcaprub_c extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/pcaprub_c V=1
+ cp ext/pcaprub_c/pcaprub_c$(get_modname) lib || die
+}