summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/pcaprub/pcaprub-0.13.1.ebuild')
-rw-r--r--dev-ruby/pcaprub/pcaprub-0.13.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/pcaprub/pcaprub-0.13.1.ebuild b/dev-ruby/pcaprub/pcaprub-0.13.1.ebuild
new file mode 100644
index 000000000000..a2557b0dd274
--- /dev/null
+++ b/dev-ruby/pcaprub/pcaprub-0.13.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="FAQ.rdoc README.rdoc USAGE.rdoc"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/pcaprub_c/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Libpcap bindings for ruby compat"
+HOMEPAGE="https://rubygems.org/gems/pcaprub"
+
+LICENSE="LGPL-2.1"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DEPEND+="net-libs/libpcap"
+RDEPEND+="net-libs/libpcap"
+
+# Tests require live access to a network device as root.
+RESTRICT="test"