summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/pg')
-rw-r--r--dev-ruby/pg/Manifest1
-rw-r--r--dev-ruby/pg/pg-1.2.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/pg/Manifest b/dev-ruby/pg/Manifest
index a7240dce2bae..68d2b51a8cf6 100644
--- a/dev-ruby/pg/Manifest
+++ b/dev-ruby/pg/Manifest
@@ -1 +1,2 @@
DIST pg-1.2.2.gem 196608 BLAKE2B 068be98d190cb4074cc89bdb5b376322f323950909f7a6fddc8669a3ff0f85eef9f512bd2ec7121707e9ea077b2b428f698e84f2118c76e34f5def75ca303fca SHA512 5c7cc90afb75a66e80cfc34c4875cf22b005aa0a27e78db6f71d1829f870c6409b73326a9925f79c0d642e93ea51d1f84c7383323fea44b7488e83deb7754951
+DIST pg-1.2.3.gem 196608 BLAKE2B b3e9119d068c833f7352b61802d5fb03616ed2d13f957c8d4b51966444523ef9d884a860309209dfbda5931aa1f8199b7a63a51a89c194758de309f00bdbfbd6 SHA512 dd8fa7b256102aea7588fd7e1d4e28199be2bf9910149d266b5379e78a7a57aa2a22763d04a559f4763842cad4ba8d0fbc33e8b43b7497dc77039edfd1029585
diff --git a/dev-ruby/pg/pg-1.2.3.ebuild b/dev-ruby/pg/pg-1.2.3.ebuild
new file mode 100644
index 000000000000..a3608ddcd972
--- /dev/null
+++ b/dev-ruby/pg/pg-1.2.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog Contributors.rdoc README.rdoc History.rdoc"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby extension library providing an API to PostgreSQL"
+HOMEPAGE="https://github.com/ged/ruby-pg"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND+=" dev-db/postgresql:*"
+DEPEND+=" dev-db/postgresql
+ test? ( >=dev-db/postgresql-9.4[server(+),threads] )"
+
+all_ruby_prepare() {
+ # hack the Rakefile to make it sure that it doesn't load
+ # rake-compiler (so that we don't have to depend on it and it
+ # actually works when building with USE=doc).
+ sed -i \
+ -e '/Rakefile.cross/s:^:#:' \
+ -e '/ExtensionTask/,/^end$/ s:^:#:' \
+ Rakefile || die
+}
+
+each_ruby_test() {
+ if [[ "${EUID}" -ne "0" ]]; then
+ # Make the rspec call explicit, this way we don't have to depend
+ # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
+ # the whole extension from scratch.
+ RSPEC_VERSION=3 ruby-ng_rspec
+ else
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+}