summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/pg')
-rw-r--r--dev-ruby/pg/Manifest1
-rw-r--r--dev-ruby/pg/pg-1.3.5.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-ruby/pg/Manifest b/dev-ruby/pg/Manifest
index 68d2b51a8cf6..4961707bf6bd 100644
--- a/dev-ruby/pg/Manifest
+++ b/dev-ruby/pg/Manifest
@@ -1,2 +1,3 @@
DIST pg-1.2.2.gem 196608 BLAKE2B 068be98d190cb4074cc89bdb5b376322f323950909f7a6fddc8669a3ff0f85eef9f512bd2ec7121707e9ea077b2b428f698e84f2118c76e34f5def75ca303fca SHA512 5c7cc90afb75a66e80cfc34c4875cf22b005aa0a27e78db6f71d1829f870c6409b73326a9925f79c0d642e93ea51d1f84c7383323fea44b7488e83deb7754951
DIST pg-1.2.3.gem 196608 BLAKE2B b3e9119d068c833f7352b61802d5fb03616ed2d13f957c8d4b51966444523ef9d884a860309209dfbda5931aa1f8199b7a63a51a89c194758de309f00bdbfbd6 SHA512 dd8fa7b256102aea7588fd7e1d4e28199be2bf9910149d266b5379e78a7a57aa2a22763d04a559f4763842cad4ba8d0fbc33e8b43b7497dc77039edfd1029585
+DIST pg-1.3.5.tar.gz 256197 BLAKE2B 8a8cd0135eb7dcf8389d2b0afa174059d12f542b1e2897fba0e292fd16f31508293ca90f64f731db9bc14e55e9ba2c740ccf744a5fe30c449d64344264e409e1 SHA512 44e8ad97a6f4136d49641c5a59a70a489d766d1c1e511f5a6f003c2ae2900466b02a2504dc0fb26c872ce3fcb56ac83ac5299a829cca99d9c02c4b7ce0f0ac75
diff --git a/dev-ruby/pg/pg-1.3.5.ebuild b/dev-ruby/pg/pg-1.3.5.ebuild
new file mode 100644
index 000000000000..a041e4e6ee51
--- /dev/null
+++ b/dev-ruby/pg/pg-1.3.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_GEMSPEC="pg.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="Contributors.rdoc README.rdoc History.rdoc"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby extension library providing an API to PostgreSQL"
+HOMEPAGE="https://github.com/ged/ruby-pg"
+SRC_URI="https://github.com/ged/ruby-pg/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-${P}"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND+=" dev-db/postgresql:*"
+DEPEND+=" dev-db/postgresql
+ test? ( >=dev-db/postgresql-9.4[server(+),threads] )"
+
+all_ruby_prepare() {
+ # hack the Rakefile to make it sure that it doesn't load
+ # rake-compiler (so that we don't have to depend on it and it
+ # actually works when building with USE=doc).
+ sed -i \
+ -e '/Rakefile.cross/s:^:#:' \
+ -e '/ExtensionTask/,/^end$/ s:^:#:' \
+ Rakefile || die
+
+ sed -e 's/git ls-files -z/find * -print0/' \
+ -e "s:_relative ': './:" \
+ -e 's/__dir__/"."/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid tests that assume IPv4
+ sed -i -e '/expect.*hostaddr/ s:^:#:' spec/pg/connection_spec.rb || die
+
+ # Avoid test that only works with bundled pg
+ sed -i -e '/tells about the libpq library path/askip "gentoo"' spec/pg_spec.rb || die
+}
+
+each_ruby_test() {
+ if [[ "${EUID}" -ne "0" ]]; then
+ # Make the rspec call explicit, this way we don't have to depend
+ # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
+ # the whole extension from scratch.
+ RSPEC_VERSION=3 ruby-ng_rspec
+ else
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+}