summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/podcast')
-rw-r--r--dev-ruby/podcast/podcast-0.0.4-r3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/podcast/podcast-0.0.4-r3.ebuild b/dev-ruby/podcast/podcast-0.0.4-r3.ebuild
new file mode 100644
index 000000000000..0da4506b3d80
--- /dev/null
+++ b/dev-ruby/podcast/podcast-0.0.4-r3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby library for generating podcasts from mp3 files"
+HOMEPAGE="http://podcast.rubyforge.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+
+ruby_add_rdepend "dev-ruby/ruby-mp3info"
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/ts_podcast.rb || die "Tests failed."
+}