summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/racc')
-rw-r--r--dev-ruby/racc/Manifest1
-rw-r--r--dev-ruby/racc/racc-1.4.14.ebuild67
2 files changed, 0 insertions, 68 deletions
diff --git a/dev-ruby/racc/Manifest b/dev-ruby/racc/Manifest
index d70c87d37a80..c0c099c42b1f 100644
--- a/dev-ruby/racc/Manifest
+++ b/dev-ruby/racc/Manifest
@@ -1,3 +1,2 @@
-DIST racc-1.4.14.gem 116224 BLAKE2B 67abd0e9bed46d7c589c62426943c8594d3b119328cd08576247727b11beb9e32ea45c54d0aadefc26691972fc40aad1b009c55bcd90a5b89aaf37e37a1097c1 SHA512 7401ad1722c92101c24f881226e44bd8b21033c7bae8b13cbf329f9b426c312ce61d14ce584b4f94d6863b77f30d6ebccf26f9fca2de724f8e0659f0e2d2173f
DIST racc-1.4.16.tar.gz 451711 BLAKE2B d3bcb72a69df255d5468054541c281bf7bd3225eb3ba1997fccd6dcd219d3a8890e3df7b43fe106ffa3fc63a8d8079cab83e7096b0737f5bbacf816b7c3bbfb2 SHA512 7cdf6a62449e8f39984a8b27706045e509828a93a72d112b22a4c467184a63ee23b4b2048ef7017846053fb2ff4021aa43d96a6147fa271257df584ab3d66f38
DIST racc-1.5.2.tar.gz 434903 BLAKE2B cfbaa09c1b2e233e82228075cf979c54688e51e702cade072d42b2952100b74a53e536d904cbbf15cb04ffc74018b48e5b27a5773adf6240614c815250d47119 SHA512 73c68dd75fa35727fd93a76886dd77afbb7032271e535c6e885a4ede6822052a93a610dec8a1f84daf24903c749b30a185831ec96d651588db2a2524f3dcd477
diff --git a/dev-ruby/racc/racc-1.4.14.ebuild b/dev-ruby/racc/racc-1.4.14.ebuild
deleted file mode 100644
index 37c88a48322c..000000000000
--- a/dev-ruby/racc/racc-1.4.14.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc README.ja.rdoc TODO ChangeLog"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A LALR(1) parser generator for Ruby"
-HOMEPAGE="https://github.com/tenderlove/racc"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="~alpha amd64 arm arm64 hppa ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-ruby_add_rdepend "virtual/ruby-ssl"
-
-ruby_add_bdepend "dev-ruby/rake
- test? ( >=dev-ruby/minitest-4.0:0 )"
-
-all_ruby_prepare() {
- sed -i -e 's|/tmp/out|${TMPDIR:-/tmp}/out|' test/helper.rb || die "tests fix failed"
-
- # Avoid depending on rake-compiler since we don't use it to compile
- # the extension.
- sed -i -e '/rake-compiler/ s:^:#:' -e '/extensiontask/ s:^:#:' Rakefile
- sed -i -e '/ExtensionTask/,/^ end/ s:^:#:' Rakefile
-
- # Avoid isolation since dependencies are not properly declared.
- sed -i -e 's/, :isolate//' Rakefile || die
-
- # Use a version of the minitest gem that works consistently accross
- # all ruby versions.
- sed -i -e '2i gem "minitest", "~>4.0"' test/helper.rb || die
-}
-
-each_ruby_prepare() {
- ${RUBY} -Cext/racc extconf.rb || die
-}
-
-each_ruby_compile() {
- emake V=1 -Cext/racc
- # Copy over the file here so that we don't have to do
- # special ruby install for JRuby and the other
- # implementations.
- cp -l ext/racc/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:. -e "Dir['test/test_*.rb'].each{|f| require f}" || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- dodoc -r rdoc
-
- docinto examples
- dodoc -r sample
-}