summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rake/rake-13.1.0.ebuild')
-rw-r--r--dev-ruby/rake/rake-13.1.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-ruby/rake/rake-13.1.0.ebuild b/dev-ruby/rake/rake-13.1.0.ebuild
index 4ce7d447e2c7..2b254de6cfb7 100644
--- a/dev-ruby/rake/rake-13.1.0.ebuild
+++ b/dev-ruby/rake/rake-13.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -43,7 +43,7 @@ all_ruby_compile() {
}
each_ruby_test() {
- ${RUBY} -Ilib:test:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+ MT_NO_PLUGINS=true RUBYLIB="$(pwd)/lib" ${RUBY} -Ilib:test:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
}
all_ruby_install() {