summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rake/rake-13.1.0.ebuild')
-rw-r--r--dev-ruby/rake/rake-13.1.0.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-ruby/rake/rake-13.1.0.ebuild b/dev-ruby/rake/rake-13.1.0.ebuild
new file mode 100644
index 000000000000..9e314a7afdda
--- /dev/null
+++ b/dev-ruby/rake/rake-13.1.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.rdoc TODO"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_BINDIR="exe"
+
+RUBY_FAKEGEM_GEMSPEC="rake.gemspec"
+
+inherit bash-completion-r1 ruby-fakegem
+
+DESCRIPTION="Make-like scripting in Ruby"
+HOMEPAGE="https://github.com/ruby/rake"
+SRC_URI="https://github.com/ruby/rake/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc"
+
+BDEPEND+=" app-alternatives/gzip"
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.8 )
+ doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare() {
+ sed -e 's/git ls-files -z/find * -type f -print0/' \
+ -e 's:_relative ": "./:' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_compile() {
+ if use doc; then
+ rdoc --title "Rake - Ruby Make" --main README.rdoc --out html lib *.rdoc doc/*/*.rdoc || die
+ rm -f html/js/*.js.gz
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}
+
+all_ruby_install() {
+ ruby_fakegem_binwrapper rake
+
+ if use doc; then
+ pushd html
+ dodoc -r *
+ popd
+ fi
+
+ doman doc/rake.1
+
+ newbashcomp "${FILESDIR}"/rake.bash-completion ${PN}
+}