summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rb-inotify/rb-inotify-0.9.10-r1.ebuild')
-rw-r--r--dev-ruby/rb-inotify/rb-inotify-0.9.10-r1.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-ruby/rb-inotify/rb-inotify-0.9.10-r1.ebuild b/dev-ruby/rb-inotify/rb-inotify-0.9.10-r1.ebuild
deleted file mode 100644
index b516935037a8..000000000000
--- a/dev-ruby/rb-inotify/rb-inotify-0.9.10-r1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A thorough inotify wrapper for Ruby using FFI"
-HOMEPAGE="https://github.com/nex3/rb-inotify"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend "dev-ruby/ffi"
-
-all_ruby_prepare() {
- # Avoid unneeded dependency on jeweler.
- sed -i -e '/:build/ s:^:#:' -e '/module Jeweler/,/^end/ s:^:#:' -e '/class Jeweler/,/^end/ s:^:#:' Rakefile || die
-
- # Remove mandatory markup processor from yard options, bug 436112.
- sed -i -e '/maruku/d' .yardopts || die
-
- sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
-}