summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/request_store/request_store-1.4.0.ebuild')
-rw-r--r--dev-ruby/request_store/request_store-1.4.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/request_store/request_store-1.4.0.ebuild b/dev-ruby/request_store/request_store-1.4.0.ebuild
new file mode 100644
index 000000000000..ab89379ff34b
--- /dev/null
+++ b/dev-ruby/request_store/request_store-1.4.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Per-request global storage for Rack"
+HOMEPAGE="https://github.com/steveklabnik/request_store"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rack-1.4:*"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/ s:^:#:" Rakefile || die
+}