summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/request_store/request_store-1.6.0.ebuild')
-rw-r--r--dev-ruby/request_store/request_store-1.6.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/request_store/request_store-1.6.0.ebuild b/dev-ruby/request_store/request_store-1.6.0.ebuild
new file mode 100644
index 000000000000..405c3fc00680
--- /dev/null
+++ b/dev-ruby/request_store/request_store-1.6.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Per-request global storage for Rack"
+HOMEPAGE="https://github.com/steveklabnik/request_store"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+ruby_add_rdepend ">=dev-ruby/rack-1.4:*"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/ s:^:#:" Rakefile || die
+}