summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rkelly-remix/rkelly-remix-0.0.7.ebuild')
-rw-r--r--dev-ruby/rkelly-remix/rkelly-remix-0.0.7.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/rkelly-remix/rkelly-remix-0.0.7.ebuild b/dev-ruby/rkelly-remix/rkelly-remix-0.0.7.ebuild
new file mode 100644
index 000000000000..dd61f8b84ef1
--- /dev/null
+++ b/dev-ruby/rkelly-remix/rkelly-remix-0.0.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RKelly Remix is a fork of the RKelly JavaScript parser"
+HOMEPAGE="https://github.com/nene/rkelly-remix"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0"
+IUSE="doc"
+
+ruby_add_bdepend "doc? ( dev-ruby/hoe dev-ruby/rdoc )"
+
+each_ruby_test() {
+ ${RUBY} -S testrb -Ilib:. test/test_*.rb test/*/test_*.rb || die
+}