summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rqrcode/rqrcode-0.10.1.ebuild')
-rw-r--r--dev-ruby/rqrcode/rqrcode-0.10.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/rqrcode/rqrcode-0.10.1.ebuild b/dev-ruby/rqrcode/rqrcode-0.10.1.ebuild
new file mode 100644
index 000000000000..bc4bc4edd95c
--- /dev/null
+++ b/dev-ruby/rqrcode/rqrcode-0.10.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for encoding QR Codes"
+HOMEPAGE="https://whomwah.github.com/rqrcode/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/chunky_png:0"
+
+all_ruby_prepare() {
+ sed -i -e '1igem "minitest"' test/test_helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e "Dir['test/test_r*.rb'].each{|f| require f}"
+}