summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rspec-pending_for/rspec-pending_for-0.1.16.ebuild')
-rw-r--r--dev-ruby/rspec-pending_for/rspec-pending_for-0.1.16.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/rspec-pending_for/rspec-pending_for-0.1.16.ebuild b/dev-ruby/rspec-pending_for/rspec-pending_for-0.1.16.ebuild
new file mode 100644
index 000000000000..3270a09848cf
--- /dev/null
+++ b/dev-ruby/rspec-pending_for/rspec-pending_for-0.1.16.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="rspec-pending_for.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Mark specs pending or skipped for specific Ruby engine / version combinations"
+HOMEPAGE="https://github.com/pboling/rspec-pending_for"
+SRC_URI="https://github.com/pboling/rspec-pending_for/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/rspec-core
+ dev-ruby/ruby_engine:2
+ dev-ruby/ruby_version:1
+"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/ s:^:#:' spec/spec_helper.rb || die
+}