summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rss/rss-0.2.9.ebuild')
-rw-r--r--dev-ruby/rss/rss-0.2.9.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/rss/rss-0.2.9.ebuild b/dev-ruby/rss/rss-0.2.9.ebuild
new file mode 100644
index 000000000000..182408525a62
--- /dev/null
+++ b/dev-ruby/rss/rss-0.2.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Family of libraries that support various formats of XML feeds."
+HOMEPAGE="https://github.com/ruby/rss"
+
+LICENSE="BSD-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="test"
+
+ruby_add_rdepend "dev-ruby/rexml"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/^helper.install/ s:^:#:' Rakefile || die
+}