summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.4.3.ebuild')
-rw-r--r--dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.4.3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.4.3.ebuild b/dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.4.3.ebuild
new file mode 100644
index 000000000000..33937efa3d4c
--- /dev/null
+++ b/dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.4.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_NAME="gdk_pixbuf2"
+
+inherit ruby-ng-gnome2
+
+RUBY_S=ruby-gnome-${PV}/gdk_pixbuf2
+
+DESCRIPTION="Ruby GdkPixbuf2 bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND+=" test? ( x11-libs/gdk-pixbuf[jpeg] )"
+RDEPEND+=" x11-libs/gdk-pixbuf[introspection]"
+
+ruby_add_rdepend "~dev-ruby/ruby-gio2-${PV}"