summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-hmac/ruby-hmac-0.4.0-r2.ebuild')
-rw-r--r--dev-ruby/ruby-hmac/ruby-hmac-0.4.0-r2.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-ruby/ruby-hmac/ruby-hmac-0.4.0-r2.ebuild b/dev-ruby/ruby-hmac/ruby-hmac-0.4.0-r2.ebuild
index bdb99d38044c..713c1da14f64 100644
--- a/dev-ruby/ruby-hmac/ruby-hmac-0.4.0-r2.ebuild
+++ b/dev-ruby/ruby-hmac/ruby-hmac-0.4.0-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30"
+USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
@@ -14,7 +14,7 @@ HOMEPAGE="http://ruby-hmac.rubyforge.org/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-ruby_add_bdepend "
- test? ( >=dev-ruby/hoe-2.5.0 )"
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_hmac.rb || die
+}