summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-openid/ruby-openid-2.9.2.ebuild')
-rw-r--r--dev-ruby/ruby-openid/ruby-openid-2.9.2.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-ruby/ruby-openid/ruby-openid-2.9.2.ebuild b/dev-ruby/ruby-openid/ruby-openid-2.9.2.ebuild
index 12c8796205e4..ffcefcbc6ac1 100644
--- a/dev-ruby/ruby-openid/ruby-openid-2.9.2.ebuild
+++ b/dev-ruby/ruby-openid/ruby-openid-2.9.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30"
+USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md NOTICE UPGRADE.md"
@@ -20,8 +20,16 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE="test"
+ruby_add_bdepend "test? ( dev-ruby/webrick )"
+
all_ruby_prepare() {
sed -i -e "/[Bb]undler/d" Rakefile || die
+
+ # Avoid test failing due to new sematics in ruby 3
+ sed -i -e '/test_no_host/askip "Ruby 3 incompatibility"' test/test_discover.rb || die
+
+ # Fix Bignum deprecation in tests
+ sed -i -e 's/Bignum/Integer/' test/test_cryptutil.rb || die
}
all_ruby_install() {