summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rubytter/rubytter-1.5.1-r2.ebuild')
-rw-r--r--dev-ruby/rubytter/rubytter-1.5.1-r2.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-ruby/rubytter/rubytter-1.5.1-r2.ebuild b/dev-ruby/rubytter/rubytter-1.5.1-r2.ebuild
deleted file mode 100644
index ceca69b7b4e4..000000000000
--- a/dev-ruby/rubytter/rubytter-1.5.1-r2.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby27 ruby30"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc examples/*"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Rubytter is a simple twitter library"
-HOMEPAGE="https://wiki.github.com/jugyo/rubytter"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/json-1.1.3:* >=dev-ruby/oauth-0.3.6"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/d' -e '/check_dependencies/ s:^:#:' Rakefile || die
-
- # Make specs work with rspec 3
- sed -i -e 's/stub!/stub/ ; 250 s/pending/skip/' spec/rubytter_spec.rb || die
-
- # Make specs work with ruby30
- sed -i -e '27i{' -e '30i}' spec/rubytter/oauth_spec.rb || die
-}