summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rubyzip/rubyzip-1.2.0.ebuild')
-rw-r--r--dev-ruby/rubyzip/rubyzip-1.2.0.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-ruby/rubyzip/rubyzip-1.2.0.ebuild b/dev-ruby/rubyzip/rubyzip-1.2.0.ebuild
deleted file mode 100644
index 0e7fd7d4f909..000000000000
--- a/dev-ruby/rubyzip/rubyzip-1.2.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md TODO"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A ruby library for reading and writing zip files"
-HOMEPAGE="https://github.com/rubyzip/rubyzip"
-# Tests are not included in the gem.
-SRC_URI="https://github.com/rubyzip/rubyzip/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="Ruby"
-SLOT="1"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${DEPEND} test? ( app-arch/zip )"
-
-ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc samples/*
-}
-
-all_ruby_prepare() {
- # Avoid dependencies on simplecov and coveralls
- sed -i -e '/simplecov/ s:^:#:' test/test_helper.rb || die
-
- # Avoid dependency on bundler
- sed -i -e '/bundler/ s:^:#:' Rakefile || die
-
- # Fix hardcoded path to /tmp
- sed -i -e 's:/tmp/:'${T}'/:g' test/entry_test.rb || die
-
- # Add missing require
- sed -i -e '1irequire "forwardable"' test/input_stream_test.rb || die
-}