summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rubyzip')
-rw-r--r--dev-ruby/rubyzip/Manifest3
-rw-r--r--dev-ruby/rubyzip/rubyzip-1.3.0.ebuild52
-rw-r--r--dev-ruby/rubyzip/rubyzip-2.2.0.ebuild49
-rw-r--r--dev-ruby/rubyzip/rubyzip-2.3.2-r1.ebuild (renamed from dev-ruby/rubyzip/rubyzip-2.3.0.ebuild)12
-rw-r--r--dev-ruby/rubyzip/rubyzip-2.3.2.ebuild54
5 files changed, 6 insertions, 164 deletions
diff --git a/dev-ruby/rubyzip/Manifest b/dev-ruby/rubyzip/Manifest
index b0d8f9f9c9a4..218936ed3a05 100644
--- a/dev-ruby/rubyzip/Manifest
+++ b/dev-ruby/rubyzip/Manifest
@@ -1,4 +1 @@
-DIST rubyzip-1.3.0-git.tgz 156664 BLAKE2B 2bde6515ddc71da32fc2d2819770857f7dde8605718c868f73edb8493f7db5ce66a7115d09933ffc6a06ac0979ab07e8cbdcd47984707688b7a5db43394847bc SHA512 5a764725d1f6a797f710581dbe07bd7971f0a8a5b0ffb7fc9b1a627c32e6e342ff54e2ad39e74e294dd283b8cbf358ed2dc40857f6f656007adff80d4769b9f4
-DIST rubyzip-2.2.0-git.tgz 224109 BLAKE2B b1d879d04c4bd23f32f82260d386a0b0ff8bb4c1af705a4eca9fc279b4095551edad27e2187aa146b9c76f183df2687fc03dd7c6d62c2dde6d70c9137226316c SHA512 c10f3574c7948ae29ed665de69f79d714e146bda27a634c3bfdf7210240b535c6a9fba43fff0228fd85afd262ca56d25002393eda90237d8da1034edda62e2a7
-DIST rubyzip-2.3.0-git.tgz 225336 BLAKE2B 24b00e02c26881953c843761d38b8bf3a9a5a04da6cafa73bea6abdeea345a71a31241a557ff3c182df274210a970f17b3e866657153784df6b03cdf472681f6 SHA512 da9c446aa1a3c457decdaedb387f4030f84a2b1c1c3ca14a0e8588103f95cf893812e7a146362c083aba478828ccda4b127cd0b80fa2fa09022e06ad041506bf
DIST rubyzip-2.3.2-git.tgz 225923 BLAKE2B ed901326cd0f79c8be004d9c14b32d7e67e90ab4d2d5b67dc64559fd4691dfb63cfa1ee18363a7cf864bd62559f1bc2fae71fc25ad1c727d7cc01f94d1ec62ee SHA512 6c64e53c1f5ca530abfa22baf388f87c8cf098d81cc9c639f20903e5193cf26243fbf861ac12002ae954f026e04168d8a55beeaf3ac5542bd0618ca85a5c90de
diff --git a/dev-ruby/rubyzip/rubyzip-1.3.0.ebuild b/dev-ruby/rubyzip/rubyzip-1.3.0.ebuild
deleted file mode 100644
index 20c157d72842..000000000000
--- a/dev-ruby/rubyzip/rubyzip-1.3.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md TODO"
-
-RUBY_FAKEGEM_GEMSPEC="rubyzip.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A ruby library for reading and writing zip files"
-HOMEPAGE="https://github.com/rubyzip/rubyzip"
-# Tests are not included in the gem.
-SRC_URI="https://github.com/rubyzip/rubyzip/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="Ruby"
-SLOT="1"
-KEYWORDS="amd64 arm ~arm64 ~hppa ppc ppc64 sparc x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${DEPEND} test? ( app-arch/zip )"
-
-ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc samples/*
-}
-
-all_ruby_prepare() {
- # Avoid dependencies on simplecov and coveralls
- sed -i -e '/simplecov/ s:^:#:' test/test_helper.rb || die
-
- # Avoid dependency on bundler
- sed -i -e '/bundler/ s:^:#:' Rakefile || die
-
- # Fix hardcoded path to /tmp
- sed -i -e 's:/tmp/:'${T}'/:g' test/entry_test.rb || die
-
- # Add missing requires
- sed -i -e '1irequire "forwardable"; require "pathname"' test/input_stream_test.rb || die
-
- # Fix broken test that uses native endian
- sed -i -e '/pack/ s/LLS/VVv/' test/file_extract_test.rb || die
-}
diff --git a/dev-ruby/rubyzip/rubyzip-2.2.0.ebuild b/dev-ruby/rubyzip/rubyzip-2.2.0.ebuild
deleted file mode 100644
index 35b67483c881..000000000000
--- a/dev-ruby/rubyzip/rubyzip-2.2.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md TODO"
-
-RUBY_FAKEGEM_GEMSPEC="rubyzip.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A ruby library for reading and writing zip files"
-HOMEPAGE="https://github.com/rubyzip/rubyzip"
-# Tests are not included in the gem.
-SRC_URI="https://github.com/rubyzip/rubyzip/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="Ruby"
-SLOT="$(ver_cut 1)"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${DEPEND} test? ( app-arch/zip )"
-
-ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc samples/*
-}
-
-all_ruby_prepare() {
- # Avoid dependencies on simplecov and coveralls
- sed -i -e '/simplecov/ s:^:#:' test/test_helper.rb || die
-
- # Avoid dependency on bundler
- sed -i -e '/bundler/ s:^:#:' Rakefile || die
-
- # Fix hardcoded path to /tmp
- sed -i -e 's:/tmp/:'${T}'/:g' test/entry_test.rb || die
-
- # Add missing requires
- sed -i -e '1irequire "forwardable"; require "pathname"' test/input_stream_test.rb || die
-}
diff --git a/dev-ruby/rubyzip/rubyzip-2.3.0.ebuild b/dev-ruby/rubyzip/rubyzip-2.3.2-r1.ebuild
index 63b3c7e93be4..54f13b3b2f7f 100644
--- a/dev-ruby/rubyzip/rubyzip-2.3.0.ebuild
+++ b/dev-ruby/rubyzip/rubyzip-2.3.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_RECIPE_DOC="none"
RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md TODO"
@@ -19,9 +19,9 @@ HOMEPAGE="https://github.com/rubyzip/rubyzip"
# Tests are not included in the gem.
SRC_URI="https://github.com/rubyzip/rubyzip/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-LICENSE="Ruby"
+LICENSE="Ruby-BSD"
SLOT="$(ver_cut 1)"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE=""
RDEPEND=""
@@ -44,7 +44,7 @@ all_ruby_prepare() {
sed -i -e '/bundler/ s:^:#: ; /rubocop/I s:^:#:' Rakefile || die
# Fix hardcoded path to /tmp
- sed -i -e 's:/tmp/:'${T}'/:g' test/entry_test.rb || die
+ sed -i -e "s:/tmp/:${T}/:g" test/entry_test.rb || die
# Add missing requires
sed -i -e '1irequire "forwardable"; require "pathname"' test/input_stream_test.rb || die
diff --git a/dev-ruby/rubyzip/rubyzip-2.3.2.ebuild b/dev-ruby/rubyzip/rubyzip-2.3.2.ebuild
deleted file mode 100644
index aef8a552c081..000000000000
--- a/dev-ruby/rubyzip/rubyzip-2.3.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md TODO"
-
-RUBY_FAKEGEM_GEMSPEC="rubyzip.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="A ruby library for reading and writing zip files"
-HOMEPAGE="https://github.com/rubyzip/rubyzip"
-# Tests are not included in the gem.
-SRC_URI="https://github.com/rubyzip/rubyzip/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="Ruby"
-SLOT="$(ver_cut 1)"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${DEPEND} test? ( app-arch/zip )"
-
-ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc samples/*
-}
-
-all_ruby_prepare() {
- # Avoid dependencies on simplecov and coveralls
- sed -i -e '/simplecov/ s:^:#:' test/test_helper.rb || die
-
- # Avoid dependency on bundler
- sed -i -e '/bundler/ s:^:#: ; /rubocop/I s:^:#:' Rakefile || die
-
- # Fix hardcoded path to /tmp
- sed -i -e 's:/tmp/:'${T}'/:g' test/entry_test.rb || die
-
- # Add missing requires
- sed -i -e '1irequire "forwardable"; require "pathname"' test/input_stream_test.rb || die
-
- # Fix broken test that uses native endian
- sed -i -e '/pack/ s/LLS/VVv/' test/file_extract_test.rb || die
-}