summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/securerandom/securerandom-0.2.2.ebuild')
-rw-r--r--dev-ruby/securerandom/securerandom-0.2.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/securerandom/securerandom-0.2.2.ebuild b/dev-ruby/securerandom/securerandom-0.2.2.ebuild
new file mode 100644
index 000000000000..180c2687ae21
--- /dev/null
+++ b/dev-ruby/securerandom/securerandom-0.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="securerandom.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Interface for secure random number generator"
+HOMEPAGE="https://github.com/ruby/securerandom"
+SRC_URI="https://github.com/ruby/securerandom/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}