summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/sexp_processor/sexp_processor-4.17.1.ebuild')
-rw-r--r--dev-ruby/sexp_processor/sexp_processor-4.17.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/sexp_processor/sexp_processor-4.17.1.ebuild b/dev-ruby/sexp_processor/sexp_processor-4.17.1.ebuild
new file mode 100644
index 000000000000..0b0afbdcef7c
--- /dev/null
+++ b/dev-ruby/sexp_processor/sexp_processor-4.17.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Processor for s-expressions created as part of the ParseTree project"
+HOMEPAGE="https://www.zenspider.com/projects/sexp_processor.html"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/minitest-5.5
+ )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}