summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/simplecov-html/simplecov-html-0.12.3-r1.ebuild')
-rw-r--r--dev-ruby/simplecov-html/simplecov-html-0.12.3-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/simplecov-html/simplecov-html-0.12.3-r1.ebuild b/dev-ruby/simplecov-html/simplecov-html-0.12.3-r1.ebuild
new file mode 100644
index 000000000000..54f720024239
--- /dev/null
+++ b/dev-ruby/simplecov-html/simplecov-html-0.12.3-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="assets public views"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generates a HTML report of your SimpleCov ruby code coverage results"
+HOMEPAGE="https://github.com/simplecov-ruby/simplecov"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~riscv"
+SLOT="$(ver_cut 1-2)"
+IUSE="doc"